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Installation tiamo 2.x

1 Minimum system requirements
Operating system

32-bit version of:
￭
￭
￭
￭
￭
￭
￭
￭
￭

Windows 10 Pro / Enterprise
Windows 8.1 Professional / Enterprise
Windows 8 Professional / Enterprise
Windows 7 Professional / Ultimate / Enterprise
Windows Vista Business / Enterprise / Ultimate
Windows XP Professional SP2
Windows Server 2008 R2
Windows Server 2008
Windows Server 2003

64-bit version of:
￭
￭
￭
￭
￭
￭
￭

RAM

Windows 10 Pro / Enterprise
Windows 8.1 Professional / Enterprise
Windows 8 Professional / Enterprise
Windows 7 Professional / Ultimate / Enterprise
Windows Server 2012 R2
Windows Server 2012
Windows Server 2008 R2

Windows Vista and higher: 2 GB
Windows XP: 1 GB

Hard disk space

Program: 1 GB
Data: 2 GB

Serial ports

for devices with RS-232 interface

USB ports

for devices with USB interface

Screen

Resolution: 1024 x 768

Network

10 Mbit/s, stable and permanent
Communication via TCP/IP

The Windows user must have administrator rights in order to be able to install
the tiamo software.
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CAUTION

Data loss may occur if the PC switches to sleep mode during a determination. The sleep mode should therefore be disabled in the energy settings
of the operating system.

2 Single workplace installation
With the single workplace version tiamo light or tiamo Full, you can install
both the tiamo client and the server on the computer.
1 The installation process starts automatically when you insert the CD into
the drive. If this option is deactivated on your computer, double-click on
the setup.exe file.
If the minimum system requirements are not met (see above) an appropriate message appears. Click on [Yes] if you would like to install the program nonetheless.
Afterwards, click on [Next >].
2 During the installation process, the Welcome screen appears first. Click on
[Next >] to install the software.
3 After having read the license agreement for tiamo and accepted it with
[Yes], a window will appear where you can enter the license code.

4 Enter the license code for tiamo light or tiamo Full and then click on
[Next >].
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NOTE

If you have entered the license code of an update license, then the
license code of the previous full version will additionally be requested.

5 Now confirm the target folder for the tiamo installation with [Next >] or
select a different target folder with [Browse…].
6 You can define the paths for the database and default backup files in the
Additional installation information window:
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NOTE

The default paths are different for Windows XP, Windows Vista, Windows 7 and Windows 8.
The database path must not be on a network drive.
The default backup path may be on a network drive.
You can change the ports tiamo uses to communicate with the database
server and the administration server with the [Advanced…] button. If
the ports are already used, an appropriate error message will appear. Ask
your system administrator for more information about this. Continue with
[Next >].
7 Follow the instructions of the program until the following message
appears:

This message points out again which ports tiamo uses. Write down these
ports and inform your system administrator in case tiamo is not able to
connect to the database. Confirm the message with [OK].
tiamo will now be installed.
8 Once the copying procedure has been completed you can make further
workplace settings:
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The option This client ID must exist in the current tiamo system.
can only be activated if a database from a previous installation already
exists on your computer or if you want to connect to a database server
which is installed on another computer (the latter case only applies to
tiamo multi).
If you enable this option, then tiamo checks whether the identifier you
have entered exists in the database. If this is true the identifier and all
associated settings will be adopted. With this option reinstalling a client is
much easier.
Click on [Next >]. If the database ports are not available, an appropriate
error message will appear and the installation will be canceled. In this
case, check your server and firewall settings before installing the program
again.
9 At the end of the installation, the file info.txt will be created. This file
contains all relevant information concerning your current tiamo installation. Save this file on your hard drive for future reference and print it (add
to IQ).
NOTE

An InstallLog file can be found in the installation directory of tiamo
under …bin\InstallLog. It contains a listing of all files copied to your
computer during the installation and a confirmation that the installation has been successfully completed.
10 Complete the installation with [Finish].

3 Client/server installation
With the tiamo multi version (multi-client version with three licenses), you can
select during the installation whether you want to install only a client or a client and a server (database server) on your computer.
If you want to install only a client on your computer, a server to which the client will be connected must have been previously installed on another computer.
1 Follow steps 1 to 5 of the single workplace installation (see Chapter 2,
page 2).
2 The Additional installation information dialog appears. Here you can
select whether you want to install only a client or a client and a server
(database server) on your computer.
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The option Client/Server installs the client and the database server on
your computer. Select this option if your computer will be used as server.
NOTE

The default paths are different for Windows XP, Windows Vista, Windows 7 and Windows 8.
The database path must not be on a network drive.
The default backup path may be on a network drive.
With Client, only the client will be installed, and, with the button
,you have to select the database server (has to be installed in advance!)
you would like to use. The network server name or the IP address is
accepted as the name.
You can change the ports which tiamo uses to communicate with the
database and administration server under [Advanced…]. If the ports are
already used, an appropriate error message will appear. Ask your system
administrator for more information about this. Continue with [Next >].
3 All further installation steps correspond to those of the single workplace
installation from point 7 onwards (see Chapter 2, page 2).

4 Modifying/repairing/removing the installation
and upgrading the license
In order to carry out modifications on the current tiamo installation, start the
setup.exe file on the installation CD or click under:
￭

6

Windows XP - Control Panel ▶ Software
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￭

Windows Vista / Windows 7 / Windows 8 - Control Panel ▶ Programs
and Features

on Metrohm tiamo. Then select Change/Remove:

Modify
With this option you can adjust the paths to the database and backup files,
and change the ports which tiamo uses for communication. With the tiamo
multi version, you can additionally change the path to the database server.
If the database path is changed, the existing databases are automatically copied to the new location.
Repair/Update
With this option you can repair an existing defective installation or update an
older installation.
￭

￭

Repairing the installation
In case of a defective tiamo installation because, for instance, a DLL file is
missing or a program file has been deleted by mistake, tiamo can be
repaired with this option.
Updating the installation
In case an older version of tiamo is installed, it will be updated to the new
version of tiamo, see Program update with tiamo light/full or Program
update with tiamo multi.
CAUTION

When older tiamo versions (1.x) are updated to tiamo 2.x, the databases will
be converted to the new version; depending on the size of the database,
this may take some time. For each database a progress bar which informs
about the status of the conversion is displayed.
The computer must not be restarted and Windows must not be shut down
as long as the conversion is running!
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License upgrade
A direct upgrade of your current installation to a tiamo version with additional
features is possible with this option:
￭
￭

tiamo light to tiamo full or tiamo multi
tiamo full to tiamo multi

In order to do this, enter your new license code in the next dialog window.
Remove
This option removes your tiamo installation. Data which has been generated
after the installation (e.g. database entries, log files, exported data, etc.) will
not be deleted.

5 Program update with tiamo light/full
During the program update, the configuration database (system configuration,
methods, templates) and the determination databases are automatically
updated for further use with the new version.
NOTE

The files in the database and backup directory will be retained when the
program is updated.
Files in the subdirectories bin, jre, lib, res, doc and examples will be overwritten by the update. Those files in these directories which are not updated
during the update will be deleted. The deleted files are listed in the InstallLog.
CAUTION

When older tiamo versions (1.x) are updated to tiamo 2.x, the databases will
be converted to the new version; depending on the size of the database,
this may take some time. For each database a progress bar which informs
about the status of the conversion is displayed.
The computer must not be restarted and Windows must not be shut down
as long as the conversion is running!
1 Save the configuration database into an external directory using the
backup function of tiamo. In the Configuration program part, select the
File ▶ Backup ▶ Manually menu item. Select Backup directory, enter
a name for the backup file and click on [Start]. The backup is carried out.
Afterwards, copy the backup file to CD/DVD.
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2 If desired, export the methods in addition to the backup with the configuration database (see above) into an external directory. In the Method
program part, select the File ▶ Method manager... menu item. Select
the desired Method group, select all methods to be exported and click
on [Edit] ▶ Export…. Select the desired export directory and click on
[OK]. The methods are exported into the desired directory. Afterwards,
copy the method files to CD/DVD.
3 Save all determination databases created by you into an external directory
using the backup function of tiamo. In the Database program part,
select the File ▶ Database manager… menu item. Select the desired
database and click on [Backup]. Select the Backup directory, enter a
name for the backup file and click on [Start]. The backup is carried out.
Afterwards, copy the backup file to CD/DVD.
4 Save further files created by you in the installation directory (e.g. export
files) into an external directory or to CD/DVD.
5 Close tiamo. Insert the installation CD and open the setup.exe file. Then
select Repair/Update and click on [Next >].

6 When updating older tiamo versions (1.x) to tiamo 2.x, you have to enter
your update license code and then click on [Next >].
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7 Complete the installation with [Finish].
NOTE

An UpdateLog file with a list of all files that have been copied to your
computer during the program update and with a confirmation of a successful installation is saved in the tiamo installation folder under
…bin\InstallLog.

6 Program update with tiamo multi
During the program update, the configuration database (system configuration,
methods, templates, user-specific data for all clients) and the determination
databases on the server are automatically updated for further use with the new
version of tiamo multi.
NOTE

The files in the database and backup directory will be retained when the
program is updated.
Files in the subdirectories bin, jre, lib, res, doc and examples will be overwritten by the update. Those files in these directories which are not updated
during the update will be deleted. The deleted files are listed in the InstallLog.
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CAUTION

When older tiamo versions (1.x) are updated to tiamo 2.x, the databases will
be converted to the new version; depending on the size of the database,
this may take some time. For each database a progress bar which informs
about the status of the conversion is displayed.
The computer must not be restarted and Windows must not be shut down
as long as the conversion is running!
1 Make sure tiamo multi is closed on all clients.
NOTE

In the bin subdirectory of the tiamo installation, you can find the Clients.exe application, with which all clients and their status can be displayed.
2 Open tiamo multi on the server and save the configuration database
into an external directory using the backup function of tiamo. In the
Configuration program part, select the File ▶ Save ▶ Manually menu
item. Select the Backup directory, enter a name for the backup file and
click on [Start]. The backup is carried out. Afterwards, copy the backup
file to CD/DVD.
3 If desired, export the methods in addition to the backup with the configuration database (see above) into an external directory. In the Method
program part, select the File ▶ Method manager… menu item. Select
the desired Method group, select all methods to be exported and click
on [Edit] ▶ Export…. Select the desired export directory and click on
[OK]. The methods are exported into the desired directory. Afterwards,
copy the method files to CD/DVD.
4 Save all determination databases on the server into an external directory
using the backup function of tiamo. In the Database program part,
select the File ▶ Database manager… menu item. Select the desired
database and click on [Backup]. Select the Backup directory, enter a
name for the backup file and click on [Start]. The backup is carried out.
Afterwards, copy the backup file to CD/DVD.
5 Save further files in the installation directory (e.g. export files) into an
external directory or to CD/DVD.
6 Updating the server
Close tiamo multi on the server and on all clients. Insert the installation
CD on the server and open the setup.exe file. Then select Repair/
Update and click on [Next >].
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7 When updating older tiamo versions (1.x) to tiamo 2.x, you have to enter
your update license code and then click on [Next >].

8

NOTE

The update of tiamo multi consists of the server license and three client licenses. If an existing installation contains additional client licenses,
these will be deleted.
Click on [OK] in the corresponding message in order to continue the
installation.
9 Complete the installation with [Finish].
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NOTE

An UpdateLog file with a list of all files that have been copied to the
server during the program update and with a confirmation of a successful installation is saved in the installation folder of tiamo under
bin\InstallLog.
10 In case additional licenses have been removed during the server update or
if further licenses are to be added, the Administrator can enter them in
tiamo (dialog: Configuration ▶ Tools ▶ Program administration ▶ Licenses ▶ Add licenses).
11 Updating clients
For each client, insert the installation CD and open the setup.exe file.
Then select Repair/Update and click on [Next >]. Complete the installation with [Finish].
NOTE

In order to facilitate the updating of many clients, the installation can
be copied from the CD to a writeable medium and the file
tiamo_init.ini can be modified. There, user-defined parameters for the
installation (license code, installation path, server name, etc.) can be set
in advance, which allows you to only have to click through the installation.
NOTE

An UpdateLog file with a list of all files that have been copied to the
client computer during the program update and with a confirmation of
a successful installation is saved in the client's tiamo installation folder
under bin\InstallLog.

7 Installation of drivers
In normal cases, the installation routine of tiamo automatically installs all the
drivers necessary for controlling the supported devices.
If you are using a 64-bit operating system, it may be necessary to install drivers
manually in combination with a few devices. This is the case if the operating
system displays a message when connecting a device to the computer, e.g.
Device driver software was not installed. No driver found. The message should also show the name of the corresponding device. Write down this
name and proceed as follows to install the driver manually:
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NOTE

The following description applies for Windows 7 (64-bit version). It may
slightly vary for your system.
1 Open the Windows Device Manager. The corresponding device can be
found under Other devices.
2 Right-click on the device. The context menu opens.
3 In the context menu, select Update Driver Software…. A dialog window opens.
4 Select Browse my computer for driver software. The file selection
dialog opens.
5 Navigate to the installation folder of tiamo (default: C\Program Files
(x86)\Metrohm\tiamo).
6 In the installation folder, open the drivers subfolder. This folder contains
the Avantes subfolder, in which you can find the driver for the Avantes
spectrometer.
7 In the drivers subfolder, open the subfolder of the corresponding device
and select the driver file (*.inf).
8 Apply the selection with [OK]. A Windows safety prompt is displayed. In
order to install the driver, click on [Install].
9 After successful installation, close the Device Manager.

8 Adding additional licenses with Windows Vista
or newer
General
Starting with Windows Vista, Microsoft has introduced the UAC (User Account
Control), which permits running tasks either as non-administrator or as administrator (without changes of user, switching off or similar).
http://technet.microsoft.com/en-us/library/cc709691%28WS.10%29.aspx
http://technet.microsoft.com/en-us/magazine/2007.06.uac.aspx
This function can, however, cause difficulties with client/server installations of
tiamo.
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Problem description
A user would like to add additional licenses for the program; the license code
for an additional five licenses, for example, is added (on the server) in the Configuration program part in the Program administration dialog window
(accessible via the Tools ▶ Program administration... menu item, Licenses
tab).
The file license.mlic, which contains the standard license code and the additional license codes, is stored in the bin directory of the program installation
(C:\Program Files\Metrohm\tiamo\bin).
If the user adds the five licenses and then looks at this license.mlic file, only
the standard license code will be listed (for three licenses).
If the user highlights the license.mlic file and clicks on Compatibility files in
the bar, then he or she will be taken to the C:\Users\'User'\AppData\Local
\VirtualStore\Program Files\Metrohm\tiamo\bin directory ('User' being
the unique identifier (UID) of the user logged in on the operating system). The
license.mlic file with the license codes for the standard licenses and the five
newly added licenses can be found here, i.e., the additional licenses are stored
in the VirtualStore only for the Windows user who was logged in on the PC
at the time the additional licenses were added.
On the server, the program recognizes all of the licenses. The operating system
adds the license.mlic file from the C:\Users\'User'\AppData\Local\VirtualStore\Program Files\tiamo\bin directory to the detail list of the C:\Program Files\Metrohm\tiamo\bin directory.
For the client/server functionality of the database server, however, the
license.mlic file in the C:\Program Files\Metrohm\tiamo\bin directory is
relevant, and here only the basic license is listed. Therefore, problems are to be
anticipated when adding additional clients (more than the three clients present
in the default settings).
Remedy
￭
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For new installations
– To enter additional licenses, you must start the program as an administrator (right-click on the program icon and select Run as administrator there).
– If you then add the license code for additional licenses in the usual
way, then the license.mlic file in the C:\Program Files\Metrohm
\tiamo\bin directory will contain both license codes.
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￭

For existing installations
– First of all, the license.mlic file in the C:\Users\'User'\AppData
\Local\VirtualStore\Program Files\Metrohm\tiamo\bin directory must be deleted.
This file must not be present in the VirtualStore of any user – you
must check to make sure this is the case, and any such files which
may be found must be deleted.
– Afterwards, you must start the program as an administrator (rightclick on the program icon and select Run as administrator there).
If you then add the license code for additional licenses in the usual
way, then the license.mlic file in the C:\Program Files\Metrohm
\tiamo\bin directory will contain both license codes.

9 User rights for tiamo
In order for the logged-in user to be able to access all functions with tiamo,
the Windows system administrator must ensure that the permissions are set for
the directories as listed below:
Directory

Permission

Group name or
user name

Database directory

Modify

SYSTEM
User*

Directory where the databases will be saved (…\Data).
Modify

User*

%ALLUSERSPROFILE%\Application Data\Metrohm
(Windows XP)**

Modify

User*

%PROGRAMDATA%\Metrohm (Windows Vista and
higher) **

Modify

User*

Export directories

Modify

User*

Modify

User*

Desktop

Modify

User*

%PROGRAMFILES%\Metrohm\tiamo

Read & execute

User*

Read & execute

User*

Backup directory
Directory where the backups will be stored (…\Backup).

Directories where the exported files are to be saved.
PDF directories
Directories where the PDF files are to be saved.

(32-bit version of Windows versions)
%PROGRAMFILES(x86)%\Metrohm\tiamo
(64-bit version of Windows versions)
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*

User = name of the user who is logged in

**

During installation of tiamo the permission Full Control is set for the following groups: SYSTEM, Administrators, Users, Guests, Main users.
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NOTE

The BackupServer.exe process must be started for carrying out a backup
(backup of the configuration database and of the determination databases).
You can check this under "Windows Task Manager".
The user must be logged in during the whole backup process.

8.101.8056EN / 2017-01-10

17

